Should contest rules allow and act upon 599K QRM reports?

Saturday, 17 August 2013

KX3 KXFL3

A big improvement recently by Elecraft. A hardware fix on the KXFL3 dual pass-band roofing filter has removed the tuning noise clearly audible above 21MHz. The loud brrrrrrrrrrrrrrp! on moving the VFO dial has now gone! Hats off to Elecraft for finding this problem and publishing the fix. However, I did have the disappointment of having to put up with this problem for 6 months and would like to vent my frustrations. I had assigned the KX3 to the bucket, but now I'm starting to play with it again. How did it ever leave the factory like this? Surely during IVVQ testing they turned the VFO on a fully loaded KX3 above 21MHz? However, not every user noticed this problem, going by the number of 5/5 scores on EHAM. My only salvation during this period was a German ham DL7VDX (far enough away from the USA mojo to critise) who posted evidence of this fault on youtube (thanks Ron by the way). (http://www.youtube.com/watch?v=GRL4W9ZTbQ0) I could hear my KX3 tuning noise on 10m above the normal 51-2 background noise that a 3 element monoband yagi provides to the rx. Does this mean that quality control at Elecraft is variable to say the least? Maybe my KX3 was a Friday afternoon beer time pup. But lets get back to the fix. Initially we all had to put up with nonsense suggestions and menu fixes like enabling the 8KHz rx shift (which disabled the KXFL3) or enabling the VFO NR (to try to hide the problem in firmware). This reminds me of similar ridiculus suggestions on how to fix the speaker problem, like "just change the AGC threshold to 4 and the rumbling speaker problem goes away!".... please, if you don't know what AGC threshold does, don't open your mouth :-). Anyway I digress, the actual fault brings into question the PCB layout quality at Elecraft. The fix was in hardware and consisted of 3 pins being cut off the KXFL3 connector. These pins formed a serial link to a surplus EEPROM on the KXFL3 board. Altough these serial links seem innocuous in terms of operational frequency (100KHz->400KHz) they contain harmonics (due to clock and data pulse edges) which stretch up into the HF domain. PCB layout of these links needs special attention to ground return signal paths to avoid these harmonics straying from directly below the links (good design) and instead going into other sensitive circuits (bad design). All that is required to prevent this is an uninterrupted ground plane directly below the serial link. I suspect that the Elecraft's modular architecture is a victim of it's own success here, as passing these signals from board to board presents signal integrity problems manifesting in a brrrrrrrrrrp! out the speaker! There are other rx problems apparent only on tuning that disappear when you stop turning the VFO. No one else seems to have noticed them yet, but if you are a cw operator and stop on weak signals in a busy band you'll know what I'm talking about. Opposite sideband supression is suspect coupled with heavy firmware stitching to hide it. I'm still uncertain wether I'll ever be able to use this radio in favour of my K2. I'd like to end this rant on a high note as although I'm moaning here, there is no company out there that comes closer to understanding the customers desires than Elecraft in terms of amateur radio equipment. I'm truely grateful to Elecraft for the K2 and the K3 I own and hopefully in time the KX3 also.

No comments: